Console Output

14:56:19 Started by GitHub push by stevekuznetsov
14:56:19 [EnvInject] - Loading node environment variables.
14:56:19 Building in workspace /var/lib/jenkins/jobs/install_origin_ci_tool/workspace
14:56:19  > git rev-parse --is-inside-work-tree # timeout=10
14:56:19 Fetching changes from the remote Git repository
14:56:19  > git config remote.origin.url git@github.com:openshift/origin-ci-tool.git # timeout=10
14:56:19 Fetching upstream changes from git@github.com:openshift/origin-ci-tool.git
14:56:19  > git --version # timeout=10
14:56:19  > git fetch --tags --progress git@github.com:openshift/origin-ci-tool.git +refs/heads/*:refs/remotes/origin/*
14:56:20  > git rev-parse refs/remotes/origin/master^{commit} # timeout=10
14:56:20  > git rev-parse refs/remotes/origin/origin/master^{commit} # timeout=10
14:56:20 Checking out Revision e48441f7523e50b47f8b314ab99c6fcadb57dc83 (refs/remotes/origin/master)
14:56:20 Commit message: "Merge pull request #165 from dobbymoodge/mark-source-ami"
14:56:20  > git config core.sparsecheckout # timeout=10
14:56:20  > git checkout -f e48441f7523e50b47f8b314ab99c6fcadb57dc83
14:56:20  > git rev-list e7cdd7cefed4a2266047c3a3d0e6ab9000cf9eb1 # timeout=10
14:56:20 [workspace] $ /bin/bash /tmp/jenkins5253489721059531167.sh
14:56:20 ++ git log -n 1 --pretty=%H
14:56:20 + latest_sha=e48441f7523e50b47f8b314ab99c6fcadb57dc83
14:56:20 + venv_dir=/var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83
14:56:20 + virtualenv /var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83 --system-site-packages
14:56:20 New python executable in /var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83/bin/python
14:56:21 Installing Setuptools..............................................................................................................................................................................................................................done.
14:56:21 Installing Pip.....................................................................................................................................................................................................................................................................................................................................done.
14:56:21 + rm -f /var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83/bin/activate
14:56:21 + cat
14:56:21 + source /var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83/bin/activate
14:56:21 ++ export VIRTUAL_ENV=/var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83
14:56:21 ++ VIRTUAL_ENV=/var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83
14:56:21 ++ export PATH=/var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83/bin:/sbin:/usr/sbin:/bin:/usr/bin
14:56:21 ++ PATH=/var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83/bin:/sbin:/usr/sbin:/bin:/usr/bin
14:56:21 ++ unset PYTHON_HOME
14:56:21 + pip install --upgrade pip
14:56:23 Downloading/unpacking pip from https://files.pythonhosted.org/packages/ae/e8/2340d46ecadb1692a1e455f13f75e596d4eab3d11a57446f08259dee8f02/pip-10.0.1.tar.gz#sha256=f2bd08e0cd1b06e10218feaf6fef299f473ba706582eb3bd9d52203fdbd7ee68
14:56:23   Running setup.py egg_info for package pip
14:56:23     /usr/lib64/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
14:56:23       warnings.warn(msg)
14:56:23     
14:56:23     warning: no previously-included files found matching '.coveragerc'
14:56:23     warning: no previously-included files found matching '.mailmap'
14:56:23     warning: no previously-included files found matching '.travis.yml'
14:56:23     warning: no previously-included files found matching '.landscape.yml'
14:56:23     warning: no previously-included files found matching 'src/pip/_vendor/Makefile'
14:56:23     warning: no previously-included files found matching 'tox.ini'
14:56:23     warning: no previously-included files found matching '*-requirements.txt'
14:56:23     warning: no previously-included files found matching 'appveyor.yml'
14:56:23     warning: no previously-included files found matching 'src/pip/_vendor/six'
14:56:23     warning: no previously-included files matching '*.pyi' found under directory 'src/pip/_vendor'
14:56:23     no previously-included directories found matching '.github'
14:56:23     no previously-included directories found matching '.travis'
14:56:23     no previously-included directories found matching 'docs/build'
14:56:23     no previously-included directories found matching 'news'
14:56:23     no previously-included directories found matching 'contrib'
14:56:23     no previously-included directories found matching 'tasks'
14:56:23     no previously-included directories found matching 'tests'
14:56:23 Installing collected packages: pip
14:56:23   Found existing installation: pip 1.4.1
14:56:23     Uninstalling pip:
14:56:23       Successfully uninstalled pip
14:56:23   Running setup.py install for pip
14:56:23     /usr/lib64/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
14:56:23       warnings.warn(msg)
14:56:23     
14:56:23     warning: no previously-included files found matching '.coveragerc'
14:56:23     warning: no previously-included files found matching '.mailmap'
14:56:23     warning: no previously-included files found matching '.travis.yml'
14:56:23     warning: no previously-included files found matching '.landscape.yml'
14:56:23     warning: no previously-included files found matching 'src/pip/_vendor/Makefile'
14:56:23     warning: no previously-included files found matching 'tox.ini'
14:56:23     warning: no previously-included files found matching '*-requirements.txt'
14:56:23     warning: no previously-included files found matching 'appveyor.yml'
14:56:23     warning: no previously-included files found matching 'src/pip/_vendor/six'
14:56:23     warning: no previously-included files matching '*.pyi' found under directory 'src/pip/_vendor'
14:56:23     no previously-included directories found matching '.github'
14:56:23     no previously-included directories found matching '.travis'
14:56:23     no previously-included directories found matching 'docs/build'
14:56:23     no previously-included directories found matching 'news'
14:56:23     no previously-included directories found matching 'contrib'
14:56:23     no previously-included directories found matching 'tasks'
14:56:23     no previously-included directories found matching 'tests'
14:56:23     Installing pip script to /var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83/bin
14:56:23     Installing pip2.7 script to /var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83/bin
14:56:23     Installing pip2 script to /var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83/bin
14:56:23 Successfully installed pip
14:56:23 Cleaning up...
14:56:23 + pip install --upgrade setuptools
14:56:24 Collecting setuptools
14:56:24   Using cached https://files.pythonhosted.org/packages/8c/10/79282747f9169f21c053c562a0baa21815a8c7879be97abd930dbcf862e8/setuptools-39.1.0-py2.py3-none-any.whl
14:56:25 ruamel-yaml 0.11.11 requires ruamel.ordereddict, which is not installed.
14:56:25 Installing collected packages: setuptools
14:56:25   Found existing installation: setuptools 0.9.8
14:56:25     Uninstalling setuptools-0.9.8:
14:56:25       Successfully uninstalled setuptools-0.9.8
14:56:25 Successfully installed setuptools-39.1.0
14:56:25 + pip install . --process-dependency-links
14:56:26 Processing /var/lib/jenkins/jobs/install_origin_ci_tool/workspace
14:56:29 DEPRECATION: Dependency Links processing has been deprecated and will be removed in a future release.
14:56:29 Requirement already satisfied: Click in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (6.3)
14:56:29 Collecting ansible==3.0.0 (from origin-ci-tool==0.1.0)
14:56:29   Cloning https://github.com/stevekuznetsov/ansible.git (to revision skuznets/oct-release) to /tmp/pip-install-4BWIOH/ansible
14:56:35 Requirement already satisfied: backports.shutil_get_terminal_size in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.0.0)
14:56:35 Requirement already satisfied: semver in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (2.7.2)
14:56:35 Requirement already satisfied: junit_xml in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.7)
14:56:35 Collecting structlog (from origin-ci-tool==0.1.0)
14:56:35   Using cached https://files.pythonhosted.org/packages/e9/ea/0d4fd621c7e797ad9fa2cd0e4bd1b4b613364ecfeca39512e1fb30f43394/structlog-18.1.0-py2.py3-none-any.whl
14:56:36 Requirement already satisfied: boto3 in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.4.6)
14:56:36 Requirement already satisfied: paramiko in /usr/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (1.16.1)
14:56:36 Requirement already satisfied: jinja2 in /usr/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (2.7.2)
14:56:36 Requirement already satisfied: PyYAML in /usr/lib64/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (3.10)
14:56:36 Requirement already satisfied: setuptools in /var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (39.1.0)
14:56:36 Requirement already satisfied: pycrypto>=2.6 in /usr/lib64/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (2.6.1)
14:56:36 Requirement already satisfied: six in /usr/lib/python2.7/site-packages (from junit_xml->origin-ci-tool==0.1.0) (1.10.0)
14:56:36 Requirement already satisfied: botocore<1.7.0,>=1.6.0 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (1.6.0)
14:56:36 Requirement already satisfied: jmespath<1.0.0,>=0.7.1 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (0.9.0)
14:56:36 Requirement already satisfied: s3transfer<0.2.0,>=0.1.10 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (0.1.10)
14:56:36 Requirement already satisfied: ecdsa>=0.11 in /usr/lib/python2.7/site-packages (from paramiko->ansible==3.0.0->origin-ci-tool==0.1.0) (0.13)
14:56:36 Requirement already satisfied: markupsafe in /usr/lib64/python2.7/site-packages (from jinja2->ansible==3.0.0->origin-ci-tool==0.1.0) (0.11)
14:56:36 Requirement already satisfied: python-dateutil<3.0.0,>=1.4 in /usr/lib/python2.7/site-packages (from botocore<1.7.0,>=1.6.0->boto3->origin-ci-tool==0.1.0) (1.5)
14:56:36 Requirement already satisfied: docutils>=0.10 in /usr/lib/python2.7/site-packages (from botocore<1.7.0,>=1.6.0->boto3->origin-ci-tool==0.1.0) (0.11)
14:56:36 Requirement already satisfied: futures<4.0.0,>=2.2.0 in /usr/lib/python2.7/site-packages (from s3transfer<0.2.0,>=0.1.10->boto3->origin-ci-tool==0.1.0) (3.0.5)
14:56:36 ruamel-yaml 0.11.11 requires ruamel.ordereddict, which is not installed.
14:56:36 Installing collected packages: ansible, structlog, origin-ci-tool
14:56:36   Found existing installation: ansible 2.4.2.0
14:56:36     Not uninstalling ansible at /usr/lib/python2.7/site-packages, outside environment /var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83
14:56:36     Can't uninstall 'ansible'. No files were found to uninstall.
14:56:36   Running setup.py install for ansible: started
14:56:39     Running setup.py install for ansible: finished with status 'done'
14:56:39   Running setup.py install for origin-ci-tool: started
14:56:57     Running setup.py install for origin-ci-tool: finished with status 'done'
14:56:59 Successfully installed ansible-3.0.0 origin-ci-tool-0.1.0 structlog-18.1.0
14:57:00 + rm -f /var/lib/jenkins/origin-ci-tool/latest
14:57:00 + ln -s /var/lib/jenkins/origin-ci-tool/e48441f7523e50b47f8b314ab99c6fcadb57dc83 /var/lib/jenkins/origin-ci-tool/latest
14:57:00 Finished: SUCCESS