Console Output

15:38:23 Started by GitHub push by dobbymoodge
15:38:23 [EnvInject] - Loading node environment variables.
15:38:23 Building in workspace /var/lib/jenkins/jobs/install_origin_ci_tool/workspace
15:38:23  > git rev-parse --is-inside-work-tree # timeout=10
15:38:23 Fetching changes from the remote Git repository
15:38:23  > git config remote.origin.url git@github.com:openshift/origin-ci-tool.git # timeout=10
15:38:23 Fetching upstream changes from git@github.com:openshift/origin-ci-tool.git
15:38:23  > git --version # timeout=10
15:38:23  > git fetch --tags --progress git@github.com:openshift/origin-ci-tool.git +refs/heads/*:refs/remotes/origin/*
15:38:24  > git rev-parse refs/remotes/origin/master^{commit} # timeout=10
15:38:24  > git rev-parse refs/remotes/origin/origin/master^{commit} # timeout=10
15:38:24 Checking out Revision 7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83 (refs/remotes/origin/master)
15:38:24 Commit message: "Merge pull request #166 from dobbymoodge/image_unready"
15:38:24  > git config core.sparsecheckout # timeout=10
15:38:24  > git checkout -f 7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83
15:38:24  > git rev-list e48441f7523e50b47f8b314ab99c6fcadb57dc83 # timeout=10
15:38:24 [workspace] $ /bin/bash /tmp/jenkins3234022266694700637.sh
15:38:24 ++ git log -n 1 --pretty=%H
15:38:24 + latest_sha=7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83
15:38:24 + venv_dir=/var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83
15:38:24 + virtualenv /var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83 --system-site-packages
15:38:24 New python executable in /var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83/bin/python
15:38:24 Installing Setuptools..............................................................................................................................................................................................................................done.
15:38:25 Installing Pip.....................................................................................................................................................................................................................................................................................................................................done.
15:38:25 + rm -f /var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83/bin/activate
15:38:25 + cat
15:38:25 + source /var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83/bin/activate
15:38:25 ++ export VIRTUAL_ENV=/var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83
15:38:25 ++ VIRTUAL_ENV=/var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83
15:38:25 ++ export PATH=/var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83/bin:/sbin:/usr/sbin:/bin:/usr/bin
15:38:25 ++ PATH=/var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83/bin:/sbin:/usr/sbin:/bin:/usr/bin
15:38:25 ++ unset PYTHON_HOME
15:38:25 + pip install --upgrade pip
15:38:27 Downloading/unpacking pip from https://files.pythonhosted.org/packages/ae/e8/2340d46ecadb1692a1e455f13f75e596d4eab3d11a57446f08259dee8f02/pip-10.0.1.tar.gz#sha256=f2bd08e0cd1b06e10218feaf6fef299f473ba706582eb3bd9d52203fdbd7ee68
15:38:27   Running setup.py egg_info for package pip
15:38:27     /usr/lib64/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
15:38:27       warnings.warn(msg)
15:38:27     
15:38:27     warning: no previously-included files found matching '.coveragerc'
15:38:27     warning: no previously-included files found matching '.mailmap'
15:38:27     warning: no previously-included files found matching '.travis.yml'
15:38:27     warning: no previously-included files found matching '.landscape.yml'
15:38:27     warning: no previously-included files found matching 'src/pip/_vendor/Makefile'
15:38:27     warning: no previously-included files found matching 'tox.ini'
15:38:27     warning: no previously-included files found matching '*-requirements.txt'
15:38:27     warning: no previously-included files found matching 'appveyor.yml'
15:38:27     warning: no previously-included files found matching 'src/pip/_vendor/six'
15:38:27     warning: no previously-included files matching '*.pyi' found under directory 'src/pip/_vendor'
15:38:27     no previously-included directories found matching '.github'
15:38:27     no previously-included directories found matching '.travis'
15:38:27     no previously-included directories found matching 'docs/build'
15:38:27     no previously-included directories found matching 'news'
15:38:27     no previously-included directories found matching 'contrib'
15:38:27     no previously-included directories found matching 'tasks'
15:38:27     no previously-included directories found matching 'tests'
15:38:27 Installing collected packages: pip
15:38:27   Found existing installation: pip 1.4.1
15:38:27     Uninstalling pip:
15:38:27       Successfully uninstalled pip
15:38:27   Running setup.py install for pip
15:38:27     /usr/lib64/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
15:38:27       warnings.warn(msg)
15:38:27     
15:38:27     warning: no previously-included files found matching '.coveragerc'
15:38:27     warning: no previously-included files found matching '.mailmap'
15:38:27     warning: no previously-included files found matching '.travis.yml'
15:38:27     warning: no previously-included files found matching '.landscape.yml'
15:38:27     warning: no previously-included files found matching 'src/pip/_vendor/Makefile'
15:38:27     warning: no previously-included files found matching 'tox.ini'
15:38:27     warning: no previously-included files found matching '*-requirements.txt'
15:38:27     warning: no previously-included files found matching 'appveyor.yml'
15:38:27     warning: no previously-included files found matching 'src/pip/_vendor/six'
15:38:27     warning: no previously-included files matching '*.pyi' found under directory 'src/pip/_vendor'
15:38:27     no previously-included directories found matching '.github'
15:38:27     no previously-included directories found matching '.travis'
15:38:27     no previously-included directories found matching 'docs/build'
15:38:27     no previously-included directories found matching 'news'
15:38:27     no previously-included directories found matching 'contrib'
15:38:27     no previously-included directories found matching 'tasks'
15:38:27     no previously-included directories found matching 'tests'
15:38:27     Installing pip script to /var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83/bin
15:38:27     Installing pip2.7 script to /var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83/bin
15:38:27     Installing pip2 script to /var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83/bin
15:38:27 Successfully installed pip
15:38:27 Cleaning up...
15:38:27 + pip install --upgrade setuptools
15:38:28 Collecting setuptools
15:38:28   Using cached https://files.pythonhosted.org/packages/8c/10/79282747f9169f21c053c562a0baa21815a8c7879be97abd930dbcf862e8/setuptools-39.1.0-py2.py3-none-any.whl
15:38:28 ruamel-yaml 0.11.11 requires ruamel.ordereddict, which is not installed.
15:38:28 Installing collected packages: setuptools
15:38:28   Found existing installation: setuptools 0.9.8
15:38:28     Uninstalling setuptools-0.9.8:
15:38:28       Successfully uninstalled setuptools-0.9.8
15:38:28 Successfully installed setuptools-39.1.0
15:38:28 + pip install . --process-dependency-links
15:38:29 Processing /var/lib/jenkins/jobs/install_origin_ci_tool/workspace
15:38:32 DEPRECATION: Dependency Links processing has been deprecated and will be removed in a future release.
15:38:32 Requirement already satisfied: Click in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (6.3)
15:38:32 Collecting ansible==3.0.0 (from origin-ci-tool==0.1.0)
15:38:32   Cloning https://github.com/stevekuznetsov/ansible.git (to revision skuznets/oct-release) to /tmp/pip-install-xKSOg_/ansible
15:38:39 Requirement already satisfied: backports.shutil_get_terminal_size in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.0.0)
15:38:39 Requirement already satisfied: semver in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (2.7.2)
15:38:39 Requirement already satisfied: junit_xml in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.7)
15:38:39 Collecting structlog (from origin-ci-tool==0.1.0)
15:38:39   Using cached https://files.pythonhosted.org/packages/e9/ea/0d4fd621c7e797ad9fa2cd0e4bd1b4b613364ecfeca39512e1fb30f43394/structlog-18.1.0-py2.py3-none-any.whl
15:38:39 Requirement already satisfied: boto3 in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.4.6)
15:38:39 Requirement already satisfied: paramiko in /usr/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (1.16.1)
15:38:39 Requirement already satisfied: jinja2 in /usr/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (2.7.2)
15:38:39 Requirement already satisfied: PyYAML in /usr/lib64/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (3.10)
15:38:39 Requirement already satisfied: setuptools in /var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (39.1.0)
15:38:39 Requirement already satisfied: pycrypto>=2.6 in /usr/lib64/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (2.6.1)
15:38:39 Requirement already satisfied: six in /usr/lib/python2.7/site-packages (from junit_xml->origin-ci-tool==0.1.0) (1.10.0)
15:38:39 Requirement already satisfied: botocore<1.7.0,>=1.6.0 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (1.6.0)
15:38:39 Requirement already satisfied: jmespath<1.0.0,>=0.7.1 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (0.9.0)
15:38:39 Requirement already satisfied: s3transfer<0.2.0,>=0.1.10 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (0.1.10)
15:38:39 Requirement already satisfied: ecdsa>=0.11 in /usr/lib/python2.7/site-packages (from paramiko->ansible==3.0.0->origin-ci-tool==0.1.0) (0.13)
15:38:39 Requirement already satisfied: markupsafe in /usr/lib64/python2.7/site-packages (from jinja2->ansible==3.0.0->origin-ci-tool==0.1.0) (0.11)
15:38:39 Requirement already satisfied: python-dateutil<3.0.0,>=1.4 in /usr/lib/python2.7/site-packages (from botocore<1.7.0,>=1.6.0->boto3->origin-ci-tool==0.1.0) (1.5)
15:38:39 Requirement already satisfied: docutils>=0.10 in /usr/lib/python2.7/site-packages (from botocore<1.7.0,>=1.6.0->boto3->origin-ci-tool==0.1.0) (0.11)
15:38:39 Requirement already satisfied: futures<4.0.0,>=2.2.0 in /usr/lib/python2.7/site-packages (from s3transfer<0.2.0,>=0.1.10->boto3->origin-ci-tool==0.1.0) (3.0.5)
15:38:39 ruamel-yaml 0.11.11 requires ruamel.ordereddict, which is not installed.
15:38:39 Installing collected packages: ansible, structlog, origin-ci-tool
15:38:39   Found existing installation: ansible 2.4.2.0
15:38:39     Not uninstalling ansible at /usr/lib/python2.7/site-packages, outside environment /var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83
15:38:39     Can't uninstall 'ansible'. No files were found to uninstall.
15:38:39   Running setup.py install for ansible: started
15:38:42     Running setup.py install for ansible: finished with status 'done'
15:38:42   Running setup.py install for origin-ci-tool: started
15:39:01     Running setup.py install for origin-ci-tool: finished with status 'done'
15:39:03 Successfully installed ansible-3.0.0 origin-ci-tool-0.1.0 structlog-18.1.0
15:39:03 + rm -f /var/lib/jenkins/origin-ci-tool/latest
15:39:03 + ln -s /var/lib/jenkins/origin-ci-tool/7a5c5e83c372ad2e6b3b64b3efa16fe2cb37ef83 /var/lib/jenkins/origin-ci-tool/latest
15:39:03 Finished: SUCCESS