Console Output

14:11:47 Started by user Steve Kuznetsov
14:11:47 [EnvInject] - Loading node environment variables.
14:11:47 Building in workspace /var/lib/jenkins/jobs/install_origin_ci_tool/workspace
14:11:47 No credentials specified
14:11:47  > git rev-parse --is-inside-work-tree # timeout=10
14:11:47 Fetching changes from the remote Git repository
14:11:47  > git config remote.origin.url git@github.com:openshift/origin-ci-tool.git # timeout=10
14:11:47 Fetching upstream changes from git@github.com:openshift/origin-ci-tool.git
14:11:47  > git --version # timeout=10
14:11:47  > git fetch --tags --progress git@github.com:openshift/origin-ci-tool.git +refs/heads/*:refs/remotes/origin/*
14:11:47  > git rev-parse refs/remotes/origin/master^{commit} # timeout=10
14:11:47  > git rev-parse refs/remotes/origin/origin/master^{commit} # timeout=10
14:11:47 Checking out Revision 4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58 (refs/remotes/origin/master)
14:11:47  > git config core.sparsecheckout # timeout=10
14:11:47  > git checkout -f 4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58
14:11:47 Commit message: "Merge pull request #181 from haircommander/ansible-rhel8-2"
14:11:47  > git rev-list --no-walk 4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58 # timeout=10
14:11:47 [workspace] $ /bin/bash /tmp/jenkins5512593421452004659.sh
14:11:47 ++ git log -n 1 --pretty=%H
14:11:47 + latest_sha=4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58
14:11:47 + venv_dir=/var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58
14:11:47 + virtualenv /var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58 --system-site-packages
14:11:47 New python executable in /var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58/bin/python
14:11:47 Installing setuptools, pip, wheel...done.
14:11:49 Overwriting /var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58/bin/activate with new content
14:11:49 + rm -f /var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58/bin/activate
14:11:49 + cat
14:11:49 + source /var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58/bin/activate
14:11:49 ++ export VIRTUAL_ENV=/var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58
14:11:49 ++ VIRTUAL_ENV=/var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58
14:11:49 ++ export PATH=/var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58/bin:/sbin:/usr/sbin:/bin:/usr/bin
14:11:49 ++ PATH=/var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58/bin:/sbin:/usr/sbin:/bin:/usr/bin
14:11:49 ++ unset PYTHON_HOME
14:11:49 + pip install --upgrade 'pip<19'
14:11:50 Collecting pip<19
14:11:50   Downloading https://files.pythonhosted.org/packages/c2/d7/90f34cb0d83a6c5631cf71dfe64cc1054598c843a92b400e55675cc2ac37/pip-18.1-py2.py3-none-any.whl (1.3MB)
14:11:50 Installing collected packages: pip
14:11:50   Found existing installation: pip 19.2.3
14:11:50     Uninstalling pip-19.2.3:
14:11:50       Successfully uninstalled pip-19.2.3
14:11:51 Successfully installed pip-18.1
14:11:51 You are using pip version 18.1, however version 19.2.3 is available.
14:11:51 You should consider upgrading via the 'pip install --upgrade pip' command.
14:11:51 + pip install --upgrade setuptools
14:11:52 Requirement already up-to-date: setuptools in /var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58/lib/python2.7/site-packages (41.2.0)
14:11:52 You are using pip version 18.1, however version 19.2.3 is available.
14:11:52 You should consider upgrading via the 'pip install --upgrade pip' command.
14:11:52 + pip install . --process-dependency-links
14:11:53 Processing /var/lib/jenkins/jobs/install_origin_ci_tool/workspace
14:11:57 DEPRECATION: Dependency Links processing has been deprecated and will be removed in a future release. A possible replacement is PEP 508 URL dependencies. You can find discussion regarding this at https://github.com/pypa/pip/issues/4187.
14:11:57 Requirement already satisfied: Click in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (6.7)
14:11:57 Collecting ansible==3.0.0 (from origin-ci-tool==0.1.0)
14:11:57   Cloning https://github.com/stevekuznetsov/ansible.git (to revision skuznets/oct-release) to /tmp/pip-install-Xb4BAR/ansible
14:12:03 Switched to a new branch 'skuznets/oct-release'
14:12:03 Branch skuznets/oct-release set up to track remote branch skuznets/oct-release from origin.
14:12:04 Requirement already satisfied: backports.shutil_get_terminal_size in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.0.0)
14:12:04 Requirement already satisfied: semver in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (2.7.2)
14:12:04 Requirement already satisfied: junit_xml in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.7)
14:12:04 Collecting structlog (from origin-ci-tool==0.1.0)
14:12:04   Downloading https://files.pythonhosted.org/packages/6d/21/3b640b10c78c65819d7c6dfc46a2efcd6e9c79ee947ad0c92d661e5b79c5/structlog-19.1.0-py2.py3-none-any.whl
14:12:04 Requirement already satisfied: boto3 in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.4.6)
14:12:04 Requirement already satisfied: paramiko in /usr/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (1.16.1)
14:12:04 Requirement already satisfied: jinja2 in /usr/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (2.7.2)
14:12:04 Requirement already satisfied: PyYAML in /usr/lib64/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (3.10)
14:12:04 Requirement already satisfied: setuptools in /var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (41.2.0)
14:12:04 Requirement already satisfied: pycrypto>=2.6 in /usr/lib64/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (2.6.1)
14:12:04 Requirement already satisfied: six in /usr/lib/python2.7/site-packages (from junit_xml->origin-ci-tool==0.1.0) (1.10.0)
14:12:04 Requirement already satisfied: botocore<1.7.0,>=1.6.0 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (1.6.0)
14:12:04 Requirement already satisfied: jmespath<1.0.0,>=0.7.1 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (0.9.0)
14:12:04 Requirement already satisfied: s3transfer<0.2.0,>=0.1.10 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (0.1.10)
14:12:04 Requirement already satisfied: ecdsa>=0.11 in /usr/lib/python2.7/site-packages (from paramiko->ansible==3.0.0->origin-ci-tool==0.1.0) (0.13)
14:12:04 Requirement already satisfied: markupsafe in /usr/lib64/python2.7/site-packages (from jinja2->ansible==3.0.0->origin-ci-tool==0.1.0) (0.11)
14:12:04 Requirement already satisfied: python-dateutil<3.0.0,>=1.4 in /usr/lib/python2.7/site-packages (from botocore<1.7.0,>=1.6.0->boto3->origin-ci-tool==0.1.0) (1.5)
14:12:04 Requirement already satisfied: docutils>=0.10 in /usr/lib/python2.7/site-packages (from botocore<1.7.0,>=1.6.0->boto3->origin-ci-tool==0.1.0) (0.11)
14:12:04 Requirement already satisfied: futures<4.0.0,>=2.2.0 in /usr/lib/python2.7/site-packages (from s3transfer<0.2.0,>=0.1.10->boto3->origin-ci-tool==0.1.0) (3.1.1)
14:12:04 Building wheels for collected packages: origin-ci-tool, ansible
14:12:04   Running setup.py bdist_wheel for origin-ci-tool: started
14:12:28   Running setup.py bdist_wheel for origin-ci-tool: finished with status 'done'
14:12:28   Stored in directory: /tmp/pip-ephem-wheel-cache-ja5iSK/wheels/9b/e7/d5/d5ff012fde75c2019a8d0895331877d5a1d1f20cdf669c1e66
14:12:33   Running setup.py bdist_wheel for ansible: started
14:12:35   Running setup.py bdist_wheel for ansible: finished with status 'done'
14:12:35   Stored in directory: /tmp/pip-ephem-wheel-cache-ja5iSK/wheels/8d/4d/ae/996474d52da425371b337bd3b52ff1eb3fdd7d7dba49b26f31
14:12:36 Successfully built origin-ci-tool ansible
14:12:36 Installing collected packages: ansible, structlog, origin-ci-tool
14:12:36   Found existing installation: ansible 2.7.8
14:12:36     Not uninstalling ansible at /usr/lib/python2.7/site-packages, outside environment /var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58
14:12:36     Can't uninstall 'ansible'. No files were found to uninstall.
14:12:45 Successfully installed ansible-3.0.0 origin-ci-tool-0.1.0 structlog-19.1.0
14:12:46 You are using pip version 18.1, however version 19.2.3 is available.
14:12:46 You should consider upgrading via the 'pip install --upgrade pip' command.
14:12:46 + rm -f /var/lib/jenkins/origin-ci-tool/latest
14:12:46 + ln -s /var/lib/jenkins/origin-ci-tool/4ed73a2b2595e79f2b0d0edc9d0f621f18b6cb58 /var/lib/jenkins/origin-ci-tool/latest
14:12:46 Finished: SUCCESS