Console Output

15:07:23 Started by user Steve Kuznetsov
15:07:23 [EnvInject] - Loading node environment variables.
15:07:23 Building in workspace /var/lib/jenkins/jobs/install_origin_ci_tool/workspace
15:07:23 No credentials specified
15:07:23  > git rev-parse --is-inside-work-tree # timeout=10
15:07:23 Fetching changes from the remote Git repository
15:07:23  > git config remote.origin.url git@github.com:openshift/origin-ci-tool.git # timeout=10
15:07:23 Fetching upstream changes from git@github.com:openshift/origin-ci-tool.git
15:07:23  > git --version # timeout=10
15:07:23  > git fetch --tags --progress git@github.com:openshift/origin-ci-tool.git +refs/heads/*:refs/remotes/origin/*
15:07:24  > git rev-parse refs/remotes/origin/master^{commit} # timeout=10
15:07:24  > git rev-parse refs/remotes/origin/origin/master^{commit} # timeout=10
15:07:24 Checking out Revision 535fb569529f7bfef73145f6bb6beec55c576546 (refs/remotes/origin/master)
15:07:24  > git config core.sparsecheckout # timeout=10
15:07:24  > git checkout -f 535fb569529f7bfef73145f6bb6beec55c576546
15:07:24 Commit message: "Merge pull request #184 from haircommander/ansible-rhel8-4"
15:07:24  > git rev-list --no-walk b8c6a8622ca0f53bac92843fefb6a74d593aadb6 # timeout=10
15:07:24 [workspace] $ /bin/bash /tmp/jenkins6583198807037427071.sh
15:07:24 ++ git log -n 1 --pretty=%H
15:07:24 + latest_sha=535fb569529f7bfef73145f6bb6beec55c576546
15:07:24 + venv_dir=/var/lib/jenkins/origin-ci-tool/535fb569529f7bfef73145f6bb6beec55c576546
15:07:24 + virtualenv /var/lib/jenkins/origin-ci-tool/535fb569529f7bfef73145f6bb6beec55c576546 --system-site-packages
15:07:24 New python executable in /var/lib/jenkins/origin-ci-tool/535fb569529f7bfef73145f6bb6beec55c576546/bin/python
15:07:24 Installing setuptools, pip, wheel...done.
15:07:25 + rm -f /var/lib/jenkins/origin-ci-tool/535fb569529f7bfef73145f6bb6beec55c576546/bin/activate
15:07:25 + cat
15:07:25 + source /var/lib/jenkins/origin-ci-tool/535fb569529f7bfef73145f6bb6beec55c576546/bin/activate
15:07:25 ++ export VIRTUAL_ENV=/var/lib/jenkins/origin-ci-tool/535fb569529f7bfef73145f6bb6beec55c576546
15:07:25 ++ VIRTUAL_ENV=/var/lib/jenkins/origin-ci-tool/535fb569529f7bfef73145f6bb6beec55c576546
15:07:25 ++ export PATH=/var/lib/jenkins/origin-ci-tool/535fb569529f7bfef73145f6bb6beec55c576546/bin:/sbin:/usr/sbin:/bin:/usr/bin
15:07:25 ++ PATH=/var/lib/jenkins/origin-ci-tool/535fb569529f7bfef73145f6bb6beec55c576546/bin:/sbin:/usr/sbin:/bin:/usr/bin
15:07:25 ++ unset PYTHON_HOME
15:07:25 + pip install --upgrade 'pip<19'
15:07:26 Cache entry deserialization failed, entry ignored
15:07:26 Collecting pip<19
15:07:26   Using cached https://files.pythonhosted.org/packages/c2/d7/90f34cb0d83a6c5631cf71dfe64cc1054598c843a92b400e55675cc2ac37/pip-18.1-py2.py3-none-any.whl
15:07:26 Installing collected packages: pip
15:07:26   Found existing installation: pip 9.0.1
15:07:26     Uninstalling pip-9.0.1:
15:07:26       Successfully uninstalled pip-9.0.1
15:07:27 Successfully installed pip-18.1
15:07:27 + pip install --upgrade setuptools
15:07:28 Collecting setuptools
15:07:29   Using cached https://files.pythonhosted.org/packages/b2/86/095d2f7829badc207c893dd4ac767e871f6cd547145df797ea26baea4e2e/setuptools-41.2.0-py2.py3-none-any.whl
15:07:29 Installing collected packages: setuptools
15:07:29   Found existing installation: setuptools 28.8.0
15:07:29     Uninstalling setuptools-28.8.0:
15:07:29       Successfully uninstalled setuptools-28.8.0
15:07:29 Successfully installed setuptools-41.2.0
15:07:29 You are using pip version 18.1, however version 19.2.3 is available.
15:07:29 You should consider upgrading via the 'pip install --upgrade pip' command.
15:07:29 + pip install . --process-dependency-links
15:07:30 Processing /var/lib/jenkins/jobs/install_origin_ci_tool/workspace
15:07:32 DEPRECATION: Dependency Links processing has been deprecated and will be removed in a future release. A possible replacement is PEP 508 URL dependencies. You can find discussion regarding this at https://github.com/pypa/pip/issues/4187.
15:07:32 Requirement already satisfied: Click in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (6.7)
15:07:32 Collecting ansible==3.0.0 (from origin-ci-tool==0.1.0)
15:07:32   Cloning https://github.com/stevekuznetsov/ansible.git (to revision skuznets/oct-release) to /tmp/pip-install-jUVQPC/ansible
15:07:38 Switched to a new branch 'skuznets/oct-release'
15:07:38 Branch skuznets/oct-release set up to track remote branch skuznets/oct-release from origin.
15:07:39 Requirement already satisfied: backports.shutil_get_terminal_size in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.0.0)
15:07:39 Requirement already satisfied: semver in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (2.7.2)
15:07:39 Requirement already satisfied: junit_xml in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.7)
15:07:39 Collecting structlog (from origin-ci-tool==0.1.0)
15:07:39   Using cached https://files.pythonhosted.org/packages/6d/21/3b640b10c78c65819d7c6dfc46a2efcd6e9c79ee947ad0c92d661e5b79c5/structlog-19.1.0-py2.py3-none-any.whl
15:07:39 Requirement already satisfied: boto3 in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.4.6)
15:07:39 Requirement already satisfied: paramiko in /usr/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (1.16.1)
15:07:39 Requirement already satisfied: jinja2 in /usr/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (2.7.2)
15:07:39 Requirement already satisfied: PyYAML in /usr/lib64/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (3.10)
15:07:39 Requirement already satisfied: setuptools in /var/lib/jenkins/origin-ci-tool/535fb569529f7bfef73145f6bb6beec55c576546/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (41.2.0)
15:07:39 Requirement already satisfied: pycrypto>=2.6 in /usr/lib64/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (2.6.1)
15:07:39 Requirement already satisfied: six in /usr/lib/python2.7/site-packages (from junit_xml->origin-ci-tool==0.1.0) (1.10.0)
15:07:39 Requirement already satisfied: botocore<1.7.0,>=1.6.0 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (1.6.0)
15:07:39 Requirement already satisfied: jmespath<1.0.0,>=0.7.1 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (0.9.0)
15:07:39 Requirement already satisfied: s3transfer<0.2.0,>=0.1.10 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (0.1.10)
15:07:39 Requirement already satisfied: ecdsa>=0.11 in /usr/lib/python2.7/site-packages (from paramiko->ansible==3.0.0->origin-ci-tool==0.1.0) (0.13)
15:07:39 Requirement already satisfied: markupsafe in /usr/lib64/python2.7/site-packages (from jinja2->ansible==3.0.0->origin-ci-tool==0.1.0) (0.11)
15:07:39 Requirement already satisfied: python-dateutil<3.0.0,>=1.4 in /usr/lib/python2.7/site-packages (from botocore<1.7.0,>=1.6.0->boto3->origin-ci-tool==0.1.0) (1.5)
15:07:39 Requirement already satisfied: docutils>=0.10 in /usr/lib/python2.7/site-packages (from botocore<1.7.0,>=1.6.0->boto3->origin-ci-tool==0.1.0) (0.11)
15:07:39 Requirement already satisfied: futures<4.0.0,>=2.2.0 in /usr/lib/python2.7/site-packages (from s3transfer<0.2.0,>=0.1.10->boto3->origin-ci-tool==0.1.0) (3.1.1)
15:07:39 Building wheels for collected packages: origin-ci-tool, ansible
15:07:39   Running setup.py bdist_wheel for origin-ci-tool: started
15:08:02   Running setup.py bdist_wheel for origin-ci-tool: finished with status 'done'
15:08:02   Stored in directory: /tmp/pip-ephem-wheel-cache-updv8W/wheels/9b/e7/d5/d5ff012fde75c2019a8d0895331877d5a1d1f20cdf669c1e66
15:08:08   Running setup.py bdist_wheel for ansible: started
15:08:09   Running setup.py bdist_wheel for ansible: finished with status 'done'
15:08:09   Stored in directory: /tmp/pip-ephem-wheel-cache-updv8W/wheels/8d/4d/ae/996474d52da425371b337bd3b52ff1eb3fdd7d7dba49b26f31
15:08:10 Successfully built origin-ci-tool ansible
15:08:10 Installing collected packages: ansible, structlog, origin-ci-tool
15:08:10   Found existing installation: ansible 2.7.8
15:08:10     Not uninstalling ansible at /usr/lib/python2.7/site-packages, outside environment /var/lib/jenkins/origin-ci-tool/535fb569529f7bfef73145f6bb6beec55c576546
15:08:10     Can't uninstall 'ansible'. No files were found to uninstall.
15:08:19 Successfully installed ansible-3.0.0 origin-ci-tool-0.1.0 structlog-19.1.0
15:08:20 You are using pip version 18.1, however version 19.2.3 is available.
15:08:20 You should consider upgrading via the 'pip install --upgrade pip' command.
15:08:20 + rm -f /var/lib/jenkins/origin-ci-tool/latest
15:08:20 + ln -s /var/lib/jenkins/origin-ci-tool/535fb569529f7bfef73145f6bb6beec55c576546 /var/lib/jenkins/origin-ci-tool/latest
15:08:20 Finished: SUCCESS