Console Output

16:16:06 Started by user Scott Dodson
16:16:06 Running as SYSTEM
16:16:06 [EnvInject] - Loading node environment variables.
16:16:06 Building in workspace /var/lib/jenkins/jobs/install_origin_ci_tool/workspace
16:16:06 The recommended git tool is: NONE
16:16:06 No credentials specified
16:16:06  > git rev-parse --is-inside-work-tree # timeout=10
16:16:06 Fetching changes from the remote Git repository
16:16:06  > git config remote.origin.url git@github.com:openshift/origin-ci-tool.git # timeout=10
16:16:06 Fetching upstream changes from git@github.com:openshift/origin-ci-tool.git
16:16:06  > git --version # timeout=10
16:16:06  > git --version # 'git version 1.8.3.1'
16:16:06  > git fetch --tags --progress git@github.com:openshift/origin-ci-tool.git +refs/heads/*:refs/remotes/origin/* # timeout=10
16:16:07  > git rev-parse refs/remotes/origin/master^{commit} # timeout=10
16:16:07 Checking out Revision ecc9d7c4290a1919ea3bde21545798823a59954e (refs/remotes/origin/master)
16:16:07  > git config core.sparsecheckout # timeout=10
16:16:07  > git checkout -f ecc9d7c4290a1919ea3bde21545798823a59954e # timeout=10
16:16:07 Commit message: "Merge pull request #198 from mtnbikenc/update-package"
16:16:07  > git rev-list --no-walk 106a16ea3d38e0f479e9b45ba58fd5c40478bec2 # timeout=10
16:16:07 
[workspace] $ /bin/bash /tmp/jenkins4437436222283100313.sh 16:16:07 ++ git log -n 1 --pretty=%H 16:16:07 + latest_sha=ecc9d7c4290a1919ea3bde21545798823a59954e 16:16:07 + venv_dir=/var/lib/jenkins/origin-ci-tool/ecc9d7c4290a1919ea3bde21545798823a59954e 16:16:07 + virtualenv /var/lib/jenkins/origin-ci-tool/ecc9d7c4290a1919ea3bde21545798823a59954e --system-site-packages 16:16:07 New python executable in /var/lib/jenkins/origin-ci-tool/ecc9d7c4290a1919ea3bde21545798823a59954e/bin/python 16:16:07 Installing setuptools, pip, wheel...done. 16:16:09 + rm -f /var/lib/jenkins/origin-ci-tool/ecc9d7c4290a1919ea3bde21545798823a59954e/bin/activate 16:16:09 + cat 16:16:09 + source /var/lib/jenkins/origin-ci-tool/ecc9d7c4290a1919ea3bde21545798823a59954e/bin/activate 16:16:09 ++ export VIRTUAL_ENV=/var/lib/jenkins/origin-ci-tool/ecc9d7c4290a1919ea3bde21545798823a59954e 16:16:09 ++ VIRTUAL_ENV=/var/lib/jenkins/origin-ci-tool/ecc9d7c4290a1919ea3bde21545798823a59954e 16:16:09 ++ export PATH=/var/lib/jenkins/origin-ci-tool/ecc9d7c4290a1919ea3bde21545798823a59954e/bin:/sbin:/usr/sbin:/bin:/usr/bin 16:16:09 ++ PATH=/var/lib/jenkins/origin-ci-tool/ecc9d7c4290a1919ea3bde21545798823a59954e/bin:/sbin:/usr/sbin:/bin:/usr/bin 16:16:09 ++ unset PYTHON_HOME 16:16:09 + pip install --upgrade 'pip<19' 16:16:10 Cache entry deserialization failed, entry ignored 16:16:10 Collecting pip<19 16:16:10 Using cached https://files.pythonhosted.org/packages/c2/d7/90f34cb0d83a6c5631cf71dfe64cc1054598c843a92b400e55675cc2ac37/pip-18.1-py2.py3-none-any.whl 16:16:10 Installing collected packages: pip 16:16:10 Found existing installation: pip 9.0.1 16:16:10 Uninstalling pip-9.0.1: 16:16:10 Successfully uninstalled pip-9.0.1 16:16:11 Successfully installed pip-18.1 16:16:11 + pip install --upgrade setuptools 16:16:13 Collecting setuptools 16:16:13 Downloading https://files.pythonhosted.org/packages/e1/b7/182161210a13158cd3ccc41ee19aadef54496b74f2817cc147006ec932b4/setuptools-44.1.1-py2.py3-none-any.whl (583kB) 16:16:13 Installing collected packages: setuptools 16:16:13 Found existing installation: setuptools 28.8.0 16:16:14 Uninstalling setuptools-28.8.0: 16:16:14 Successfully uninstalled setuptools-28.8.0 16:16:14 Successfully installed setuptools-44.1.1 16:16:14 You are using pip version 18.1, however version 20.3b1 is available. 16:16:14 You should consider upgrading via the 'pip install --upgrade pip' command. 16:16:14 + pip install . --process-dependency-links 16:16:15 Processing /var/lib/jenkins/jobs/install_origin_ci_tool/workspace 16:16:20 DEPRECATION: Dependency Links processing has been deprecated and will be removed in a future release. A possible replacement is PEP 508 URL dependencies. You can find discussion regarding this at https://github.com/pypa/pip/issues/4187. 16:16:20 Requirement already satisfied: Click<7.0 in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (6.7) 16:16:20 Collecting ansible==3.0.0 (from origin-ci-tool==0.1.0) 16:16:20 Cloning https://github.com/stevekuznetsov/ansible.git (to revision skuznets/oct-release) to /tmp/pip-install-0Ngxb4/ansible 16:16:27 Switched to a new branch 'skuznets/oct-release' 16:16:27 Branch skuznets/oct-release set up to track remote branch skuznets/oct-release from origin. 16:16:28 Requirement already satisfied: backports.shutil_get_terminal_size in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.0.0) 16:16:28 Requirement already satisfied: semver in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (2.7.2) 16:16:28 Requirement already satisfied: junit_xml in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.7) 16:16:28 Collecting structlog (from origin-ci-tool==0.1.0) 16:16:28 Using cached https://files.pythonhosted.org/packages/2c/f2/6061ddd6574363534c230bbf2912596abecbda38f5fb923042313eeabc46/structlog-20.1.0-py2.py3-none-any.whl 16:16:28 Requirement already satisfied: boto3 in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.4.6) 16:16:28 Requirement already satisfied: paramiko in /usr/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (1.16.1) 16:16:28 Requirement already satisfied: jinja2 in /usr/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (2.7.2) 16:16:28 Requirement already satisfied: PyYAML in /usr/lib64/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (3.10) 16:16:28 Requirement already satisfied: setuptools in /var/lib/jenkins/origin-ci-tool/ecc9d7c4290a1919ea3bde21545798823a59954e/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (44.1.1) 16:16:28 Requirement already satisfied: pycrypto>=2.6 in /usr/lib64/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (2.6.1) 16:16:28 Requirement already satisfied: six in /usr/lib/python2.7/site-packages (from junit_xml->origin-ci-tool==0.1.0) (1.10.0) 16:16:28 Requirement already satisfied: botocore<1.7.0,>=1.6.0 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (1.6.0) 16:16:28 Requirement already satisfied: jmespath<1.0.0,>=0.7.1 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (0.9.0) 16:16:28 Requirement already satisfied: s3transfer<0.2.0,>=0.1.10 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (0.1.10) 16:16:28 Requirement already satisfied: ecdsa>=0.11 in /usr/lib/python2.7/site-packages (from paramiko->ansible==3.0.0->origin-ci-tool==0.1.0) (0.13.3) 16:16:28 Requirement already satisfied: markupsafe in /usr/lib64/python2.7/site-packages (from jinja2->ansible==3.0.0->origin-ci-tool==0.1.0) (0.11) 16:16:28 Requirement already satisfied: python-dateutil<3.0.0,>=1.4 in /usr/lib/python2.7/site-packages (from botocore<1.7.0,>=1.6.0->boto3->origin-ci-tool==0.1.0) (1.5) 16:16:28 Requirement already satisfied: docutils>=0.10 in /usr/lib/python2.7/site-packages (from botocore<1.7.0,>=1.6.0->boto3->origin-ci-tool==0.1.0) (0.11) 16:16:28 Requirement already satisfied: futures<4.0.0,>=2.2.0 in /usr/lib/python2.7/site-packages (from s3transfer<0.2.0,>=0.1.10->boto3->origin-ci-tool==0.1.0) (3.1.1) 16:16:28 Building wheels for collected packages: origin-ci-tool, ansible 16:16:28 Running setup.py bdist_wheel for origin-ci-tool: started 16:16:55 Running setup.py bdist_wheel for origin-ci-tool: finished with status 'done' 16:16:55 Stored in directory: /tmp/pip-ephem-wheel-cache-3jhaVC/wheels/9b/e7/d5/d5ff012fde75c2019a8d0895331877d5a1d1f20cdf669c1e66 16:17:01 Running setup.py bdist_wheel for ansible: started 16:17:03 Running setup.py bdist_wheel for ansible: finished with status 'done' 16:17:03 Stored in directory: /tmp/pip-ephem-wheel-cache-3jhaVC/wheels/8d/4d/ae/996474d52da425371b337bd3b52ff1eb3fdd7d7dba49b26f31 16:17:03 Successfully built origin-ci-tool ansible 16:17:03 Installing collected packages: ansible, structlog, origin-ci-tool 16:17:03 Found existing installation: ansible 2.9.1 16:17:03 Not uninstalling ansible at /usr/lib/python2.7/site-packages, outside environment /var/lib/jenkins/origin-ci-tool/ecc9d7c4290a1919ea3bde21545798823a59954e 16:17:03 Can't uninstall 'ansible'. No files were found to uninstall. 16:17:13 Successfully installed ansible-3.0.0 origin-ci-tool-0.1.0 structlog-20.1.0 16:17:15 You are using pip version 18.1, however version 20.3b1 is available. 16:17:15 You should consider upgrading via the 'pip install --upgrade pip' command. 16:17:15 + rm -f /var/lib/jenkins/origin-ci-tool/latest 16:17:15 + ln -s /var/lib/jenkins/origin-ci-tool/ecc9d7c4290a1919ea3bde21545798823a59954e /var/lib/jenkins/origin-ci-tool/latest 16:17:15 Finished: SUCCESS