Console Output

16:38:01 Started by user Scott Dodson
16:38:01 Running as SYSTEM
16:38:01 [EnvInject] - Loading node environment variables.
16:38:01 Building in workspace /var/lib/jenkins/jobs/install_origin_ci_tool/workspace
16:38:01 The recommended git tool is: NONE
16:38:01 No credentials specified
16:38:01  > git rev-parse --is-inside-work-tree # timeout=10
16:38:01 Fetching changes from the remote Git repository
16:38:01  > git config remote.origin.url git@github.com:openshift/origin-ci-tool.git # timeout=10
16:38:01 Fetching upstream changes from git@github.com:openshift/origin-ci-tool.git
16:38:01  > git --version # timeout=10
16:38:01  > git --version # 'git version 1.8.3.1'
16:38:01  > git fetch --tags --progress git@github.com:openshift/origin-ci-tool.git +refs/heads/*:refs/remotes/origin/* # timeout=10
16:38:02  > git rev-parse refs/remotes/origin/master^{commit} # timeout=10
16:38:02 Checking out Revision 95a472392910104fc805c4ab8af39791105c956d (refs/remotes/origin/master)
16:38:02  > git config core.sparsecheckout # timeout=10
16:38:02  > git checkout -f 95a472392910104fc805c4ab8af39791105c956d # timeout=10
16:38:02 Commit message: "Merge pull request #199 from mtnbikenc/fix-package"
16:38:02  > git rev-list --no-walk ecc9d7c4290a1919ea3bde21545798823a59954e # timeout=10
16:38:02 
[workspace] $ /bin/bash /tmp/jenkins3985906334059920019.sh 16:38:02 ++ git log -n 1 --pretty=%H 16:38:02 + latest_sha=95a472392910104fc805c4ab8af39791105c956d 16:38:02 + venv_dir=/var/lib/jenkins/origin-ci-tool/95a472392910104fc805c4ab8af39791105c956d 16:38:02 + virtualenv /var/lib/jenkins/origin-ci-tool/95a472392910104fc805c4ab8af39791105c956d --system-site-packages 16:38:02 New python executable in /var/lib/jenkins/origin-ci-tool/95a472392910104fc805c4ab8af39791105c956d/bin/python 16:38:02 Installing setuptools, pip, wheel...done. 16:38:04 + rm -f /var/lib/jenkins/origin-ci-tool/95a472392910104fc805c4ab8af39791105c956d/bin/activate 16:38:04 + cat 16:38:04 + source /var/lib/jenkins/origin-ci-tool/95a472392910104fc805c4ab8af39791105c956d/bin/activate 16:38:04 ++ export VIRTUAL_ENV=/var/lib/jenkins/origin-ci-tool/95a472392910104fc805c4ab8af39791105c956d 16:38:04 ++ VIRTUAL_ENV=/var/lib/jenkins/origin-ci-tool/95a472392910104fc805c4ab8af39791105c956d 16:38:04 ++ export PATH=/var/lib/jenkins/origin-ci-tool/95a472392910104fc805c4ab8af39791105c956d/bin:/sbin:/usr/sbin:/bin:/usr/bin 16:38:04 ++ PATH=/var/lib/jenkins/origin-ci-tool/95a472392910104fc805c4ab8af39791105c956d/bin:/sbin:/usr/sbin:/bin:/usr/bin 16:38:04 ++ unset PYTHON_HOME 16:38:04 + pip install --upgrade 'pip<19' 16:38:04 Cache entry deserialization failed, entry ignored 16:38:04 Collecting pip<19 16:38:04 Using cached https://files.pythonhosted.org/packages/c2/d7/90f34cb0d83a6c5631cf71dfe64cc1054598c843a92b400e55675cc2ac37/pip-18.1-py2.py3-none-any.whl 16:38:05 Installing collected packages: pip 16:38:05 Found existing installation: pip 9.0.1 16:38:05 Uninstalling pip-9.0.1: 16:38:05 Successfully uninstalled pip-9.0.1 16:38:05 Successfully installed pip-18.1 16:38:06 + pip install --upgrade setuptools 16:38:07 Collecting setuptools 16:38:07 Using cached https://files.pythonhosted.org/packages/e1/b7/182161210a13158cd3ccc41ee19aadef54496b74f2817cc147006ec932b4/setuptools-44.1.1-py2.py3-none-any.whl 16:38:07 Installing collected packages: setuptools 16:38:07 Found existing installation: setuptools 28.8.0 16:38:08 Uninstalling setuptools-28.8.0: 16:38:08 Successfully uninstalled setuptools-28.8.0 16:38:08 Successfully installed setuptools-44.1.1 16:38:08 You are using pip version 18.1, however version 20.3b1 is available. 16:38:08 You should consider upgrading via the 'pip install --upgrade pip' command. 16:38:08 + pip install . --process-dependency-links 16:38:09 Processing /var/lib/jenkins/jobs/install_origin_ci_tool/workspace 16:38:11 DEPRECATION: Dependency Links processing has been deprecated and will be removed in a future release. A possible replacement is PEP 508 URL dependencies. You can find discussion regarding this at https://github.com/pypa/pip/issues/4187. 16:38:11 Requirement already satisfied: Click<7.0 in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (6.7) 16:38:11 Collecting ansible==3.0.0 (from origin-ci-tool==0.1.0) 16:38:11 Cloning https://github.com/stevekuznetsov/ansible.git (to revision skuznets/oct-release) to /tmp/pip-install-xAVqqQ/ansible 16:38:19 Switched to a new branch 'skuznets/oct-release' 16:38:19 Branch skuznets/oct-release set up to track remote branch skuznets/oct-release from origin. 16:38:20 Requirement already satisfied: backports.shutil_get_terminal_size in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.0.0) 16:38:20 Requirement already satisfied: semver in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (2.7.2) 16:38:20 Requirement already satisfied: junit_xml in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.7) 16:38:20 Collecting structlog (from origin-ci-tool==0.1.0) 16:38:20 Using cached https://files.pythonhosted.org/packages/2c/f2/6061ddd6574363534c230bbf2912596abecbda38f5fb923042313eeabc46/structlog-20.1.0-py2.py3-none-any.whl 16:38:20 Requirement already satisfied: boto3 in /usr/lib/python2.7/site-packages (from origin-ci-tool==0.1.0) (1.4.6) 16:38:20 Requirement already satisfied: paramiko in /usr/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (1.16.1) 16:38:20 Requirement already satisfied: jinja2 in /usr/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (2.7.2) 16:38:20 Requirement already satisfied: PyYAML in /usr/lib64/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (3.10) 16:38:20 Requirement already satisfied: setuptools in /var/lib/jenkins/origin-ci-tool/95a472392910104fc805c4ab8af39791105c956d/lib/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (44.1.1) 16:38:20 Requirement already satisfied: pycrypto>=2.6 in /usr/lib64/python2.7/site-packages (from ansible==3.0.0->origin-ci-tool==0.1.0) (2.6.1) 16:38:20 Requirement already satisfied: six in /usr/lib/python2.7/site-packages (from junit_xml->origin-ci-tool==0.1.0) (1.10.0) 16:38:20 Requirement already satisfied: botocore<1.7.0,>=1.6.0 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (1.6.0) 16:38:20 Requirement already satisfied: jmespath<1.0.0,>=0.7.1 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (0.9.0) 16:38:20 Requirement already satisfied: s3transfer<0.2.0,>=0.1.10 in /usr/lib/python2.7/site-packages (from boto3->origin-ci-tool==0.1.0) (0.1.10) 16:38:20 Requirement already satisfied: ecdsa>=0.11 in /usr/lib/python2.7/site-packages (from paramiko->ansible==3.0.0->origin-ci-tool==0.1.0) (0.13.3) 16:38:20 Requirement already satisfied: markupsafe in /usr/lib64/python2.7/site-packages (from jinja2->ansible==3.0.0->origin-ci-tool==0.1.0) (0.11) 16:38:20 Requirement already satisfied: python-dateutil<3.0.0,>=1.4 in /usr/lib/python2.7/site-packages (from botocore<1.7.0,>=1.6.0->boto3->origin-ci-tool==0.1.0) (1.5) 16:38:20 Requirement already satisfied: docutils>=0.10 in /usr/lib/python2.7/site-packages (from botocore<1.7.0,>=1.6.0->boto3->origin-ci-tool==0.1.0) (0.11) 16:38:20 Requirement already satisfied: futures<4.0.0,>=2.2.0 in /usr/lib/python2.7/site-packages (from s3transfer<0.2.0,>=0.1.10->boto3->origin-ci-tool==0.1.0) (3.1.1) 16:38:20 Building wheels for collected packages: origin-ci-tool, ansible 16:38:20 Running setup.py bdist_wheel for origin-ci-tool: started 16:38:46 Running setup.py bdist_wheel for origin-ci-tool: finished with status 'done' 16:38:46 Stored in directory: /tmp/pip-ephem-wheel-cache-trTOyA/wheels/9b/e7/d5/d5ff012fde75c2019a8d0895331877d5a1d1f20cdf669c1e66 16:38:52 Running setup.py bdist_wheel for ansible: started 16:38:54 Running setup.py bdist_wheel for ansible: finished with status 'done' 16:38:54 Stored in directory: /tmp/pip-ephem-wheel-cache-trTOyA/wheels/8d/4d/ae/996474d52da425371b337bd3b52ff1eb3fdd7d7dba49b26f31 16:38:55 Successfully built origin-ci-tool ansible 16:38:55 Installing collected packages: ansible, structlog, origin-ci-tool 16:38:55 Found existing installation: ansible 2.9.1 16:38:55 Not uninstalling ansible at /usr/lib/python2.7/site-packages, outside environment /var/lib/jenkins/origin-ci-tool/95a472392910104fc805c4ab8af39791105c956d 16:38:55 Can't uninstall 'ansible'. No files were found to uninstall. 16:39:05 Successfully installed ansible-3.0.0 origin-ci-tool-0.1.0 structlog-20.1.0 16:39:06 You are using pip version 18.1, however version 20.3b1 is available. 16:39:06 You should consider upgrading via the 'pip install --upgrade pip' command. 16:39:06 + rm -f /var/lib/jenkins/origin-ci-tool/latest 16:39:06 + ln -s /var/lib/jenkins/origin-ci-tool/95a472392910104fc805c4ab8af39791105c956d /var/lib/jenkins/origin-ci-tool/latest 16:39:07 Finished: SUCCESS