FailedConsole Output

Started by upstream project "test_pr_s2i" build number 797
originally caused by:
 Started by remote host 50.17.198.52
[EnvInject] - Loading node environment variables.
Building in workspace /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace
[workspace] $ /bin/sh -xe /tmp/jenkins6188579900129906406.sh
+ vagrant origin-local-checkout --replace
You don't seem to have the GOPATH environment variable set on your system.
See: 'go help gopath' for more details about GOPATH.
Waiting for the cloning process to finish
Checking repo integrity for /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace/origin
~/jobs/test_pull_requests_s2i/workspace/origin ~/jobs/test_pull_requests_s2i/workspace
# On branch master
nothing to commit, working directory clean
~/jobs/test_pull_requests_s2i/workspace
Replacing: /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace/origin
~/jobs/test_pull_requests_s2i/workspace/origin ~/jobs/test_pull_requests_s2i/workspace
From https://github.com/openshift/origin
   bb5f71c..e674c20  master     -> origin/master
Already on 'master'
Your branch is behind 'origin/master' by 5 commits, and can be fast-forwarded.
  (use "git pull" to update your local branch)
HEAD is now at e674c20 Merge pull request #22015 from derekwaynecarr/gate-machines-aws
Removing .vagrant-openshift.json
Removing .vagrant/
fatal: branch name required
~/jobs/test_pull_requests_s2i/workspace
Origin repositories cloned into /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace
+ vagrant origin-local-checkout --replace --repo source-to-image
You don't seem to have the GOPATH environment variable set on your system.
See: 'go help gopath' for more details about GOPATH.
Waiting for the cloning process to finish
Checking repo integrity for /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace/source-to-image
~/jobs/test_pull_requests_s2i/workspace/source-to-image ~/jobs/test_pull_requests_s2i/workspace
# On branch master
# Your branch is ahead of 'origin/master' by 2 commits.
#   (use "git push" to publish your local commits)
#
nothing to commit, working directory clean
~/jobs/test_pull_requests_s2i/workspace
Replacing: /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace/source-to-image
~/jobs/test_pull_requests_s2i/workspace/source-to-image ~/jobs/test_pull_requests_s2i/workspace
Already on 'master'
Your branch is ahead of 'origin/master' by 2 commits.
  (use "git push" to publish your local commits)
HEAD is now at bb50d6f Merge pull request #947 from adambkaplan/bz-1668130
Deleted branch tpr_support-utf-8_adambkaplan (was c4df4e3).
~/jobs/test_pull_requests_s2i/workspace
Origin repositories cloned into /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace
+ '[' -n 951 ']'
+ set +x


*****Locally Merging Pull Request: https://github.com/openshift/source-to-image/pull/951
+ test_pull_requests --local_merge_pull_request 951 --repo source-to-image --config /var/lib/jenkins/.test_pull_requests_s2i.json
WARNING: Cache won't persist between runs.
  *** Starting with empty cache
Rate limit remaining: 4967
  Checking if current base repo commit ID matches what we expect
  Retrying...  attempt: 2
  Retrying...  attempt: 3
  Retrying...  attempt: 4
  Retrying...  attempt: 5
  No matching bot comment was found for pull request #951 on repo source-to-image
Local merging pull request #951 for repo 'source-to-image'
+ pushd source-to-image
+ git checkout master
Already on 'master'
+ git checkout -b tpr_support-utf-8_adambkaplan
Switched to a new branch 'tpr_support-utf-8_adambkaplan'
+ git pull git@github.com:adambkaplan/source-to-image.git support-utf-8
From github.com:adambkaplan/source-to-image
 * branch            support-utf-8 -> FETCH_HEAD
+ git pull git@github.com:adambkaplan/source-to-image.git support-utf-8 --tags
From github.com:adambkaplan/source-to-image
 * branch            support-utf-8 -> FETCH_HEAD
+ git checkout master
Switched to branch 'master'
+ git merge tpr_support-utf-8_adambkaplan
+ git submodule update --recursive
+ popd

Rate limit resets in: 19s, at 2019-02-15T00:24:17-05:00 (1550208257)
Rate limit remaining: 4965; delta: 2
Rate limit is not too low.
Would run.
Cache stats: Hits: 4, Misses: 2, Bypass: 0
      (raw): [:fresh, 4, :invalid, 0, :miss, 2, :unacceptable, 0, :valid, 0]

Done
~/jobs/test_pull_requests_s2i/workspace/source-to-image ~/jobs/test_pull_requests_s2i/workspace
Updating bb50d6f..c4df4e3
Fast-forward
 pkg/tar/tar.go      |  25 +++++++++++
 pkg/tar/tar_test.go | 127 ++++++++++++++++++++++++++++++++++++++++++++++++++--
 2 files changed, 149 insertions(+), 3 deletions(-)
Already up-to-date.
Updating bb50d6f..c4df4e3
Fast-forward
 pkg/tar/tar.go      |  25 +++++++++++
 pkg/tar/tar_test.go | 127 ++++++++++++++++++++++++++++++++++++++++++++++++++--
 2 files changed, 149 insertions(+), 3 deletions(-)
~/jobs/test_pull_requests_s2i/workspace
+ pushd origin
~/jobs/test_pull_requests_s2i/workspace/origin ~/jobs/test_pull_requests_s2i/workspace
+ vagrant origin-init --stage inst --os rhel7 --instance-type c4.large origin_test_pull_requests_s2i_1399
Reading AWS credentials from /var/lib/jenkins/.awscred
Searching devenv-rhel7_* for latest base AMI (required_name_tag=)
Found: ami-0b4c1d64a26a928c2 (devenv-rhel7_6324)
++ seq 0 2
+ for i in '$(seq 0 2)'
+ vagrant up --provider aws
There are errors in the configuration of this machine. Please fix
the following errors and try again:

shell provisioner:
* `path` for shell provisioner does not exist on the host system: /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace/origin/contrib/vagrant/provision-minimal.sh

+ echo ''\''vagrant up'\'' failed - retrying'
'vagrant up' failed - retrying
+ vagrant destroy -f
There are errors in the configuration of this machine. Please fix
the following errors and try again:

shell provisioner:
* `path` for shell provisioner does not exist on the host system: /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace/origin/contrib/vagrant/provision-minimal.sh

Build step 'Execute shell' marked build as failure
Publish artifacts to S3 Bucket No file(s) found: origin/artifacts/**
Publish artifacts to S3 Bucket ‘origin/artifacts/**’ doesn’t match anything, but ‘**’ does. Perhaps that’s what you mean?
[description-setter] Description set: <a href="https://github.com/openshift/source-to-image/pull/951">https://github.com/openshift/source-to-image/pull/951</a>
[PostBuildScript] - Executing post build scripts.
[PostBuildScript] - Build does not have any of the results []. Did not execute build step #0.
[BFA] Scanning build for known causes...
[BFA] No failure causes found
[BFA] Done. 0s
Finished: FAILURE