Console Output

Started by upstream project "test_pr_s2i" build number 802
originally caused by:
 Started by remote host 50.17.198.52
[EnvInject] - Loading node environment variables.
Building in workspace /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace
[workspace] $ /bin/sh -xe /tmp/jenkins4411048549468294497.sh
+ vagrant origin-local-checkout --replace
You don't seem to have the GOPATH environment variable set on your system.
See: 'go help gopath' for more details about GOPATH.
Waiting for the cloning process to finish
Checking repo integrity for /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace/origin
~/jobs/test_pull_requests_s2i/workspace/origin ~/jobs/test_pull_requests_s2i/workspace
# On branch master
nothing to commit, working directory clean
~/jobs/test_pull_requests_s2i/workspace
Replacing: /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace/origin
~/jobs/test_pull_requests_s2i/workspace/origin ~/jobs/test_pull_requests_s2i/workspace
From https://github.com/openshift/origin
 * [new branch]      release-4.0 -> origin/release-4.0
Already on 'master'
HEAD is now at 9bdb073 Merge pull request #21655 from JacobTanenbaum/BZ1537780
Removing .vagrant-openshift.json
Removing .vagrant/
fatal: branch name required
~/jobs/test_pull_requests_s2i/workspace
Origin repositories cloned into /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace
+ vagrant origin-local-checkout --replace --repo source-to-image
You don't seem to have the GOPATH environment variable set on your system.
See: 'go help gopath' for more details about GOPATH.
Waiting for the cloning process to finish
Checking repo integrity for /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace/source-to-image
~/jobs/test_pull_requests_s2i/workspace/source-to-image ~/jobs/test_pull_requests_s2i/workspace
# On branch master
# Your branch is ahead of 'origin/master' by 3 commits.
#   (use "git push" to publish your local commits)
#
nothing to commit, working directory clean
~/jobs/test_pull_requests_s2i/workspace
Replacing: /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace/source-to-image
~/jobs/test_pull_requests_s2i/workspace/source-to-image ~/jobs/test_pull_requests_s2i/workspace
Already on 'master'
Your branch is ahead of 'origin/master' by 3 commits.
  (use "git push" to publish your local commits)
HEAD is now at bb50d6f Merge pull request #947 from adambkaplan/bz-1668130
Deleted branch tpr_support-utf-8_adambkaplan (was 47c6847).
~/jobs/test_pull_requests_s2i/workspace
Origin repositories cloned into /var/lib/jenkins/jobs/test_pull_requests_s2i/workspace
+ '[' -n 951 ']'
+ set +x


*****Locally Merging Pull Request: https://github.com/openshift/source-to-image/pull/951
+ test_pull_requests --local_merge_pull_request 951 --repo source-to-image --config /var/lib/jenkins/.test_pull_requests_s2i.json
WARNING: Cache won't persist between runs.
  *** Starting with empty cache
Rate limit remaining: 4989
  Checking if current base repo commit ID matches what we expect
  Retrying...  attempt: 2
  Retrying...  attempt: 3
  Retrying...  attempt: 4
  Retrying...  attempt: 5
  No matching bot comment was found for pull request #951 on repo source-to-image
Local merging pull request #951 for repo 'source-to-image'
+ pushd source-to-image
+ git checkout master
Already on 'master'
+ git checkout -b tpr_support-utf-8_adambkaplan
Switched to a new branch 'tpr_support-utf-8_adambkaplan'
+ git pull git@github.com:adambkaplan/source-to-image.git support-utf-8
From github.com:adambkaplan/source-to-image
 * branch            support-utf-8 -> FETCH_HEAD
+ git pull git@github.com:adambkaplan/source-to-image.git support-utf-8 --tags
From github.com:adambkaplan/source-to-image
 * branch            support-utf-8 -> FETCH_HEAD
+ git checkout master
Switched to branch 'master'
+ git merge tpr_support-utf-8_adambkaplan
+ git submodule update --recursive
+ popd

Rate limit resets in: 2998s, at 2019-02-25T18:24:08-05:00 (1551137048)
Rate limit remaining: 4987; delta: 2
Rate limit is not too low.
Would run.
Cache stats: Hits: 4, Misses: 2, Bypass: 0
      (raw): [:fresh, 4, :invalid, 0, :miss, 2, :unacceptable, 0, :valid, 0]

Done
~/jobs/test_pull_requests_s2i/workspace/source-to-image ~/jobs/test_pull_requests_s2i/workspace
Updating bb50d6f..47c6847
Fast-forward
 hack/common.sh      |   1 +
 pkg/tar/tar.go      |  25 +++++++++++
 pkg/tar/tar_test.go | 127 ++++++++++++++++++++++++++++++++++++++++++++++++++--
 3 files changed, 150 insertions(+), 3 deletions(-)
Already up-to-date.
Updating bb50d6f..47c6847
Fast-forward
 hack/common.sh      |   1 +
 pkg/tar/tar.go      |  25 +++++++++++
 pkg/tar/tar_test.go | 127 ++++++++++++++++++++++++++++++++++++++++++++++++++--
 3 files changed, 150 insertions(+), 3 deletions(-)
~/jobs/test_pull_requests_s2i/workspace
+ pushd origin
~/jobs/test_pull_requests_s2i/workspace/origin ~/jobs/test_pull_requests_s2i/workspace
+ vagrant origin-init --stage inst --os rhel7 --instance-type c4.large origin_test_pull_requests_s2i_1408
Reading AWS credentials from /var/lib/jenkins/.awscred
Searching devenv-rhel7_* for latest base AMI (required_name_tag=)
Found: ami-0b4c1d64a26a928c2 (devenv-rhel7_6324)
++ seq 0 2
+ for i in '$(seq 0 2)'
+ vagrant up --provider aws
Bringing machine 'openshiftdev' up with 'aws' provider...
==> openshiftdev: Warning! The AWS provider doesn't support any of the Vagrant
==> openshiftdev: high-level network configurations (`config.vm.network`). They
==> openshiftdev: will be silently ignored.
==> openshiftdev: Warning! You're launching this instance into a VPC without an
==> openshiftdev: elastic IP. Please verify you're properly connected to a VPN so
==> openshiftdev: you can access this machine, otherwise Vagrant will not be able
==> openshiftdev: to SSH into it.
==> openshiftdev: Launching an instance with the following settings...
==> openshiftdev:  -- Type: c4.large
==> openshiftdev:  -- AMI: ami-0b4c1d64a26a928c2
==> openshiftdev:  -- Region: us-east-1
==> openshiftdev:  -- Keypair: libra
==> openshiftdev:  -- Subnet ID: subnet-cf57c596
==> openshiftdev:  -- User Data: yes
==> openshiftdev:  -- User Data: 
==> openshiftdev: # cloud-config
==> openshiftdev: 
==> openshiftdev: growpart:
==> openshiftdev:   mode: auto
==> openshiftdev:   devices: ['/']
==> openshiftdev: runcmd:
==> openshiftdev: - [ sh, -xc, "sed -i s/^Defaults.*requiretty/#Defaults requiretty/g /etc/sudoers"]
==> openshiftdev:         
==> openshiftdev:  -- Block Device Mapping: [{"DeviceName"=>"/dev/sda1", "Ebs.VolumeSize"=>25, "Ebs.VolumeType"=>"gp2"}, {"DeviceName"=>"/dev/sdb", "Ebs.VolumeSize"=>35, "Ebs.VolumeType"=>"gp2"}]
==> openshiftdev:  -- Terminate On Shutdown: false
==> openshiftdev:  -- Monitoring: false
==> openshiftdev:  -- EBS optimized: false
==> openshiftdev:  -- Assigning a public IP address in a VPC: false
==> openshiftdev: Waiting for instance to become "ready"...
==> openshiftdev: Waiting for SSH to become available...
==> openshiftdev: Machine is booted and ready for use!
==> openshiftdev: Running provisioner: setup (shell)...
    openshiftdev: Running: /tmp/vagrant-shell20190225-28945-nvux0i.sh
==> openshiftdev: Host: ec2-3-81-35-13.compute-1.amazonaws.com
+ break
+ vagrant ssh -c 'wget -q https://dl.google.com/go/go1.10.8.linux-amd64.tar.gz && sudo tar -C /usr/local -xzf go1.10.8.linux-amd64.tar.gz && sudo rm /bin/go* && sudo ln -s /usr/local/bin/go /usr/local/bin/godoc /usr/local/bin/gofmt /bin'
+ vagrant ssh -c 'which go'
which: no go in (/data/src/github.com/openshift/origin/_output/etcd/bin:/data/src/github.com/openshift/origin/_output/local/bin/linux/amd64:/data/bin:/usr/local/sbin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin:/home/ec2-user/.local/bin:/home/ec2-user/bin)
Build step 'Execute shell' marked build as failure
Publish artifacts to S3 Bucket No file(s) found: origin/artifacts/**
Publish artifacts to S3 Bucket ‘origin/artifacts/**’ doesn’t match anything, but ‘**’ does. Perhaps that’s what you mean?
[description-setter] Description set: <a href="https://github.com/openshift/source-to-image/pull/951">https://github.com/openshift/source-to-image/pull/951</a>
[PostBuildScript] - Executing post build scripts.
[PostBuildScript] - Build does not have any of the results []. Did not execute build step #0.
[BFA] Scanning build for known causes...
[BFA] No failure causes found
[BFA] Done. 0s
Finished: FAILURE