Started by upstream project "test_pr_s2i" build number 802 originally caused by: Started by remote host 50.17.198.52 [EnvInject] - Loading node environment variables. Building in workspace /var/lib/jenkins/jobs/test_pull_requests_s2i_windows/workspace [workspace] $ /bin/sh -xe /tmp/jenkins5861880762303361870.sh + vagrant origin-local-checkout --replace You don't seem to have the GOPATH environment variable set on your system. See: 'go help gopath' for more details about GOPATH. Waiting for the cloning process to finish Checking repo integrity for /var/lib/jenkins/jobs/test_pull_requests_s2i_windows/workspace/origin ~/jobs/test_pull_requests_s2i_windows/workspace/origin ~/jobs/test_pull_requests_s2i_windows/workspace # On branch master nothing to commit, working directory clean ~/jobs/test_pull_requests_s2i_windows/workspace Replacing: /var/lib/jenkins/jobs/test_pull_requests_s2i_windows/workspace/origin ~/jobs/test_pull_requests_s2i_windows/workspace/origin ~/jobs/test_pull_requests_s2i_windows/workspace Already on 'master' HEAD is now at 9bdb073 Merge pull request #21655 from JacobTanenbaum/BZ1537780 fatal: branch name required ~/jobs/test_pull_requests_s2i_windows/workspace Origin repositories cloned into /var/lib/jenkins/jobs/test_pull_requests_s2i_windows/workspace + vagrant origin-local-checkout --replace --repo source-to-image You don't seem to have the GOPATH environment variable set on your system. See: 'go help gopath' for more details about GOPATH. Waiting for the cloning process to finish Checking repo integrity for /var/lib/jenkins/jobs/test_pull_requests_s2i_windows/workspace/source-to-image ~/jobs/test_pull_requests_s2i_windows/workspace/source-to-image ~/jobs/test_pull_requests_s2i_windows/workspace # On branch master # Your branch is ahead of 'origin/master' by 2 commits. # (use "git push" to publish your local commits) # nothing to commit, working directory clean ~/jobs/test_pull_requests_s2i_windows/workspace Replacing: /var/lib/jenkins/jobs/test_pull_requests_s2i_windows/workspace/source-to-image ~/jobs/test_pull_requests_s2i_windows/workspace/source-to-image ~/jobs/test_pull_requests_s2i_windows/workspace Already on 'master' Your branch is ahead of 'origin/master' by 2 commits. (use "git push" to publish your local commits) HEAD is now at bb50d6f Merge pull request #947 from adambkaplan/bz-1668130 Removing .vagrant/ Deleted branch tpr_support-utf-8_adambkaplan (was c4df4e3). ~/jobs/test_pull_requests_s2i_windows/workspace Origin repositories cloned into /var/lib/jenkins/jobs/test_pull_requests_s2i_windows/workspace + '[' -n 951 ']' + set +x *****Locally Merging Pull Request: https://github.com/openshift/source-to-image/pull/951 + test_pull_requests --local_merge_pull_request 951 --repo source-to-image --config /var/lib/jenkins/.test_pull_requests_s2i.json WARNING: Cache won't persist between runs. *** Starting with empty cache Rate limit remaining: 4959 Checking if current base repo commit ID matches what we expect Retrying... attempt: 2 Retrying... attempt: 3 Retrying... attempt: 4 Retrying... attempt: 5 No matching bot comment was found for pull request #951 on repo source-to-image Local merging pull request #951 for repo 'source-to-image' + pushd source-to-image + git checkout master Already on 'master' + git checkout -b tpr_support-utf-8_adambkaplan Switched to a new branch 'tpr_support-utf-8_adambkaplan' + git pull git@github.com:adambkaplan/source-to-image.git support-utf-8 From github.com:adambkaplan/source-to-image * branch support-utf-8 -> FETCH_HEAD + git pull git@github.com:adambkaplan/source-to-image.git support-utf-8 --tags From github.com:adambkaplan/source-to-image * branch support-utf-8 -> FETCH_HEAD + git checkout master Switched to branch 'master' + git merge tpr_support-utf-8_adambkaplan + git submodule update --recursive + popd Rate limit resets in: 488s, at 2019-02-25T17:24:07-05:00 (1551133447) Rate limit remaining: 4956; delta: 3 Rate limit is not too low. Would run. Cache stats: Hits: 4, Misses: 2, Bypass: 0 (raw): [:fresh, 4, :invalid, 0, :miss, 2, :unacceptable, 0, :valid, 0] Done ~/jobs/test_pull_requests_s2i_windows/workspace/source-to-image ~/jobs/test_pull_requests_s2i_windows/workspace Updating bb50d6f..47c6847 Fast-forward hack/common.sh | 1 + pkg/tar/tar.go | 25 +++++++++++ pkg/tar/tar_test.go | 127 ++++++++++++++++++++++++++++++++++++++++++++++++++-- 3 files changed, 150 insertions(+), 3 deletions(-) Already up-to-date. Updating bb50d6f..47c6847 Fast-forward hack/common.sh | 1 + pkg/tar/tar.go | 25 +++++++++++ pkg/tar/tar_test.go | 127 ++++++++++++++++++++++++++++++++++++++++++++++++++-- 3 files changed, 150 insertions(+), 3 deletions(-) ~/jobs/test_pull_requests_s2i_windows/workspace + pushd source-to-image ~/jobs/test_pull_requests_s2i_windows/workspace/source-to-image ~/jobs/test_pull_requests_s2i_windows/workspace + export VAGRANT_VAGRANTFILE=hack/windows/Vagrantfile + VAGRANT_VAGRANTFILE=hack/windows/Vagrantfile ++ seq 0 2 + for i in '$(seq 0 2)' + USER=origin_test_pull_requests_s2i_windows_456 + vagrant up --provider aws ==> rhel: Reading AWS credentials from /var/lib/jenkins/.awscred ==> windows: Reading AWS credentials from /var/lib/jenkins/.awscred Bringing machine 'rhel' up with 'aws' provider... ==> rhel: Reading AWS credentials from /var/lib/jenkins/.awscred Bringing machine 'windows' up with 'aws' provider... ==> windows: Reading AWS credentials from /var/lib/jenkins/.awscred ==> rhel: Box 'https://github.com/mitchellh/vagrant-aws/raw/master/dummy.box' could not be found. Attempting to find and install... rhel: Box Provider: aws rhel: Box Version: >= 0 ==> rhel: Box file was not detected as metadata. Adding it directly... ==> rhel: Adding box 'https://github.com/mitchellh/vagrant-aws/raw/master/dummy.box' (v0) for provider: aws ==> windows: Box 'https://github.com/mitchellh/vagrant-aws/raw/master/dummy.box' could not be found. Attempting to find and install... ==> rhel: Reading AWS credentials from /var/lib/jenkins/.awscred windows: Box Provider: aws windows: Box Version: >= 0 ==> rhel: Reading AWS credentials from /var/lib/jenkins/.awscred ==> windows: Box file was not detected as metadata. Adding it directly... ==> windows: Adding box 'https://github.com/mitchellh/vagrant-aws/raw/master/dummy.box' (v0) for provider: aws ==> rhel: Warning! The AWS provider doesn't support any of the Vagrant ==> rhel: high-level network configurations (`config.vm.network`). They ==> rhel: will be silently ignored. ==> rhel: Searching devenv-rhel7_* for latest base AMI (required_name_tag=) ==> windows: Reading AWS credentials from /var/lib/jenkins/.awscred ==> rhel: Found: ami-0b4c1d64a26a928c2 (devenv-rhel7_6324) ==> windows: Reading AWS credentials from /var/lib/jenkins/.awscred ==> rhel: Warning! You're launching this instance into a VPC without an ==> rhel: elastic IP. Please verify you're properly connected to a VPN so ==> rhel: you can access this machine, otherwise Vagrant will not be able ==> rhel: to SSH into it. ==> windows: Warning! The AWS provider doesn't support any of the Vagrant ==> windows: high-level network configurations (`config.vm.network`). They ==> windows: will be silently ignored. ==> rhel: Launching an instance with the following settings... ==> rhel: -- Type: m4.large ==> rhel: -- AMI: ami-0b4c1d64a26a928c2 ==> windows: Searching openshift-windows2012r2_* for latest base AMI (required_name_tag=) ==> rhel: -- Region: us-east-1 ==> rhel: -- Keypair: libra ==> rhel: -- Subnet ID: subnet-cf57c596 ==> rhel: -- Block Device Mapping: [] ==> rhel: -- Terminate On Shutdown: false ==> rhel: -- Monitoring: false ==> rhel: -- EBS optimized: false ==> rhel: -- Assigning a public IP address in a VPC: false ==> windows: Found: ami-f5744be2 (openshift-windows2012r2_1480338266) ==> windows: Warning! You're launching this instance into a VPC without an ==> windows: elastic IP. Please verify you're properly connected to a VPN so ==> windows: you can access this machine, otherwise Vagrant will not be able ==> windows: to SSH into it. ==> windows: Launching an instance with the following settings... ==> windows: -- Type: m4.large ==> windows: -- AMI: ami-f5744be2 ==> windows: -- Region: us-east-1 ==> windows: -- Keypair: libra ==> windows: -- Subnet ID: subnet-cf57c596 ==> windows: -- Block Device Mapping: [] ==> windows: -- Terminate On Shutdown: false ==> windows: -- Monitoring: false ==> windows: -- EBS optimized: false ==> windows: -- Assigning a public IP address in a VPC: false ==> windows: Waiting for instance to become "ready"... ==> rhel: Waiting for instance to become "ready"... ==> windows: Waiting for SSH to become available... ==> rhel: Waiting for SSH to become available... ==> windows: Machine is booted and ready for use! ==> windows: Waiting for instance to report "Windows is Ready to use"... ==> rhel: Machine is booted and ready for use! ==> rhel: Running provisioner: configure-docker-server-linux... ==> windows: Running provisioner: configure-docker-client-windows... + break + vagrant sync-sti -c -s windows ==> windows: Reading AWS credentials from /var/lib/jenkins/.awscred Running ssh/sudo command 'rm -rf /data/src/github.com/openshift/source-to-image-bare; ' with timeout 14400. Attempt #0 Running ssh/sudo command 'mkdir -p /Administrator/.ssh; mv /tmp/file20190225-25509-1yntps8 /Administrator/.ssh/config && chown Administrator:Administrators /Administrator/.ssh/config && chmod 0600 /Administrator/.ssh/config' with timeout 14400. Attempt #0 Running ssh/sudo command 'mkdir -p /data/src/github.com/openshift/' with timeout 14400. Attempt #0 Running ssh/sudo command 'mkdir -p /data/src/github.com/openshift/builder && chown -R Administrator:Administrators /data/src/github.com/openshift/' with timeout 14400. Attempt #0 Running ssh/sudo command 'set -e rm -fr /data/src/github.com/openshift/source-to-image-bare; if [ ! -d /data/src/github.com/openshift/source-to-image-bare ]; then git clone --quiet --bare https://github.com/openshift/source-to-image.git /data/src/github.com/openshift/source-to-image-bare >/dev/null fi ' with timeout 14400. Attempt #0 Synchronizing local sources Synchronizing [source-to-image@master] from source-to-image... Warning: Permanently added '35.173.240.9' (ECDSA) to the list of known hosts. Running ssh/sudo command 'set -e if [ -d /data/src/github.com/openshift/source-to-image-bare ]; then rm -rf /data/src/github.com/openshift/source-to-image echo 'Cloning source-to-image ...' git clone --quiet --recurse-submodules /data/src/github.com/openshift/source-to-image-bare /data/src/github.com/openshift/source-to-image else MISSING_REPO+='source-to-image-bare' fi if [ -n "$MISSING_REPO" ]; then echo 'Missing required upstream repositories:' echo $MISSING_REPO echo 'To fix, execute command: vagrant clone-upstream-repos' fi ' with timeout 14400. Attempt #0 Cloning source-to-image ... Running ssh/sudo command ' pushd /data/src/github.com/openshift/source-to-image commit_id=`git rev-parse $(git rev-parse --abbrev-ref HEAD)` git_status=$(git status --porcelain) if [ -f ~/sync/source-to-image ] then previous_commit_id=$(cat ~/sync/source-to-image) fi if [ "$previous_commit_id" != "$commit_id" ] || [ -n "$git_status" ] then echo "Performing source-to-image build..." set -e hack/verify-gofmt.sh hack/build-go.sh hack/build-test-images.sh else echo "Commit ID: $commit_id" echo "Previous Commit ID: $previous_commit_id" echo "Git Status: $git_status" echo "No update for source-to-image, $(git rev-parse --abbrev-ref HEAD)" fi mkdir -p ~/sync echo -n $commit_id > ~/sync/source-to-image popd ' with timeout 14400. Attempt #0 /data/src/github.com/openshift/source-to-image ~ Performing source-to-image build... go version go1.7.1 windows/amd64 ++ Building go targets for windows/amd64: cmd/s2i # github.com/openshift/source-to-image/pkg/tar _output\local\go\src\github.com\openshift\source-to-image\pkg\tar\tar.go:335: header.Format undefined (type *tar.Header has no field or method Format) _output\local\go\src\github.com\openshift\source-to-image\pkg\tar\tar.go:335: undefined: tar.FormatPAX Error while running ssh/sudo command: pushd /data/src/github.com/openshift/source-to-image commit_id=`git rev-parse $(git rev-parse --abbrev-ref HEAD)` git_status=$(git status --porcelain) if [ -f ~/sync/source-to-image ] then previous_commit_id=$(cat ~/sync/source-to-image) fi if [ "$previous_commit_id" != "$commit_id" ] || [ -n "$git_status" ] then echo "Performing source-to-image build..." set -e hack/verify-gofmt.sh hack/build-go.sh hack/build-test-images.sh else echo "Commit ID: $commit_id" echo "Previous Commit ID: $previous_commit_id" echo "Git Status: $git_status" echo "No update for source-to-image, $(git rev-parse --abbrev-ref HEAD)" fi mkdir -p ~/sync echo -n $commit_id > ~/sync/source-to-image popd The following SSH command responded with a non-zero exit status. Vagrant assumes that this means the command failed! pushd /data/src/github.com/openshift/source-to-image commit_id=`git rev-parse $(git rev-parse --abbrev-ref HEAD)` git_status=$(git status --porcelain) if [ -f ~/sync/source-to-image ] then previous_commit_id=$(cat ~/sync/source-to-image) fi if [ "$previous_commit_id" != "$commit_id" ] || [ -n "$git_status" ] then echo "Performing source-to-image build..." set -e hack/verify-gofmt.sh hack/build-go.sh hack/build-test-images.sh else echo "Commit ID: $commit_id" echo "Previous Commit ID: $previous_commit_id" echo "Git Status: $git_status" echo "No update for source-to-image, $(git rev-parse --abbrev-ref HEAD)" fi mkdir -p ~/sync echo -n $commit_id > ~/sync/source-to-image popd Stdout from the command: /data/src/github.com/openshift/source-to-image ~ Performing source-to-image build... go version go1.7.1 windows/amd64 ++ Building go targets for windows/amd64: cmd/s2i Stderr from the command: # github.com/openshift/source-to-image/pkg/tar _output\local\go\src\github.com\openshift\source-to-image\pkg\tar\tar.go:335: header.Format undefined (type *tar.Header has no field or method Format) _output\local\go\src\github.com\openshift\source-to-image\pkg\tar\tar.go:335: undefined: tar.FormatPAX Build step 'Execute shell' marked build as failure Publish artifacts to S3 Bucket No file(s) found: source-to-image/artifacts/** Publish artifacts to S3 Bucket ‘source-to-image/artifacts/**’ doesn’t match anything, but ‘**’ does. Perhaps that’s what you mean? [description-setter] Description set: <a href="https://github.com/openshift/source-to-image/pull/951">https://github.com/openshift/source-to-image/pull/951</a> [PostBuildScript] - Executing post build scripts. [PostBuildScript] - Build does not have any of the results []. Did not execute build step #0. [BFA] Scanning build for known causes... [BFA] No failure causes found [BFA] Done. 0s Finished: FAILURE